FSLeyes (pronounced fossilise) is the new FSL image viewer, released with FSL 5.0.10.

Follow FSLeyes on Twitter to be notified of new releases.

FSLeyes can either be installed as a standalone application, or can be installed into a Python environment.

Install standalone application (recommended)

This is currently the recommended way to install FSLeyes.

Download the latest version of FSLeyes for your OS here:

If you are installing FSLeyes independently of FSL, simply unzip into a location of your choice.

If you wish to upgrade your version of FSLeyes which was installed as part of FSL (note: you may need to ask your system administrator to do this):

If the newly installed version works, you may safely remove the $FSLDIR/bin/FSLeyes.app_backup ($FSLDIR/bin/FSLeyes_backup under Linux) directory.

If you are installing FSLeyes into a version of FSL which is older than 5.0.10, you will also need to create a link to the newly installed FSLeyes:

Install into a Python environment (advanced)

This method is suitable for Python users who are comfortable creating virtual environments.

FSLeyes is available on PyPi, and should work with Python 2.7, 3.4, 3.5, and 3.6. The best way to install FSLeyes from PyPi is to create an isolated python environment with virtualenv. For example, if you are using python 3.5:

python -m venv fsleyes-virtualenv
. fsleyes-virtualenv/bin/activate

Mac users

Once you have activated your virtual environment, you should be able to install FSLeyes like so:

pip install fsleyes

Linux users

Before installing FSLeyes, you first need to install wxPython. The easiest way to do this on Linux is to use the pre-release wxPython builds available at https://extras.wxpython.org/wxPython4/extras/linux/. For example, if you are using CentOS 7:

pip install -f https://extras.wxpython.org/wxPython4/extras/linux/gtk2/centos-7 wxpython
pip install fsleyes

You will also need to install the wxPython runtime dependencies. Under CentOS 7, you will need to run the following command:

sudo yum install freeglut SDL

Similarly, under Ubuntu:

sudo apt-get install freeglut3 libsdl1.2debian

Another option is to install wxPython directly from PyPi - if you do this, you will need to have C/C++ compilers installed, and all of the dependencies required to compile wxPython. Under CentOS 7, run the following commands:

sudo yum groupinstall "Development tools"
sudo yum install gtk2-devel gtk3-devel webkitgtk-devel webkitgtk3-devel
sudo yum install libjpeg-turbo-devel libtiff-devel SDL-devel gstreamer-plugins-base-devel libnotify-devel freeglut-devel

Under Ubuntu, run the following:

sudo apt-get install build-essential
sudo apt-get install libgtk2.0-dev libgtk-3-dev libwebkitgtk-dev libwebkitgtk-3.0-dev
sudo apt-get install libjpeg-turbo8-dev libtiff5-dev libsdl1.2-dev libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev libnotify-dev freeglut3-dev

Then you should be able to pip install fsleyes as described above.

Help and troubleshooting

User documentation for FSLeyes can be found here:

https://users.fmrib.ox.ac.uk/~paulmc/fsleyes/userdoc/latest/

If you are having trouble getting FSLeyes to run, a solution may be documented on the troubleshooting page.

Development

The source code for FSLeyes and its dependent projects is hosted here:

API/developer documentation can be found here:

 

FSLeyes (last edited 13:22:38 27-06-2018 by PaulMcCarthy)